Crédito Agricola - Major Outage
Incident Report for Tink providers Portugal
Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted Mar 31, 2024 - 14:05 UTC
Investigating
We are currently investigating an issue with Crédito Agricola.
Posted Mar 31, 2024 - 06:02 UTC
This incident affected: Crédito Agricola.