Universo Bank Open Banking - Major Outage affecting Account Information Services
Incident Report for Tink providers Portugal
Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted Nov 06, 2023 - 12:04 UTC
Identified
We have identified the issue and are in contact with Universo Bank for further information.
We will update when a significant change to the situation occurs.
Posted Nov 04, 2023 - 18:50 UTC
This incident affected: Universo Bank.