EuroBic Open Banking - Aggregation Service - Major Outage

Incident Report for Tink providers Portugal

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Sep 16, 2025 - 06:53 UTC

Investigating

We are currently investigating an issue with EuroBic. An update will be posted when a significant change to the situation occurs.
Posted Sep 15, 2025 - 17:48 UTC
This incident affected: EuroBic.