Santander Open Banking - Major Outage
Incident Report for Tink providers Portugal
Identified
We have identified the issue and are in contact with Santander for further information.
We will update when a significant change to the situation occurs.
Posted Apr 24, 2024 - 06:45 UTC
Investigating
We are currently investigating an issue with Santander.
Posted Apr 22, 2024 - 17:38 UTC
This incident affects: Santander.