Millennium BCP Open banking - Partial outage
Incident Report for Tink providers Portugal
Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted Oct 22, 2024 - 07:11 UTC
Investigating
We are currently investigating an issue with Millennium BCP.
Posted Oct 17, 2024 - 12:09 UTC
This incident affected: Millennium BCP.