Universo Bank Open Banking - Major outage
Incident Report for Tink providers Portugal
Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted Dec 28, 2023 - 12:22 UTC
Identified
We have identified the issue and are in contact with Universo Bank for further information.
We will update when a significant change to the situation occurs.
Posted Dec 20, 2023 - 12:45 UTC
This incident affected: Universo Bank.