EuroBic Open Banking - Major Outage

Incident Report for Tink providers Portugal

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Sep 13, 2025 - 08:59 UTC

Update

The issue turned out to be a major outage.
Posted Sep 12, 2025 - 16:39 UTC

Investigating

We are currently investigating an issue with EuroBic Open Banking.
Posted Sep 12, 2025 - 13:56 UTC
This incident affected: EuroBic.