EuroBic - Degraded performance
Incident Report for Tink providers Portugal
Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted Jan 17, 2025 - 12:54 UTC
Investigating
We are currently investigating an issue with EuroBic.
Posted Dec 02, 2024 - 16:47 UTC
This incident affected: EuroBic.